ZF-7224: loader warnings when using class resource for a specific module

Issue Type: Bug Created: 2009-07-08T03:32:40.000+0000 Last Updated: 2009-08-10T07:37:18.000+0000 Status: Resolved Fix version(s): - 1.9.1 (11/Aug/09)

Reporter: Miroslav Kubelik (koubel) Assignee: Matthew Weier O'Phinney (matthew) Tags: - Zend_Application

Related issues: - ZF-7550

Attachments: - BootstrapAbstract.patch


I use main autoloader with enabled warnings and fallback autoloader. I also use modules bootstrap with Zend_Application_Resource_Modules. When I try to define routes for my module via module prefix as it's desribed in the manual e.g.

blog.resources.router.routes.blogIndex.route = blog blog.resources.router.routes.blogIndex.defaults.module = blog blog.resources.router.routes.blogIndex.defaults.controller = index blog.resources.router.routes.blogIndex.defaults.action = index blog.resources.router.routes.blogIndex.type = Zend_Controller_Router_Route_Static

I get these warnings

Warning: include(router.php) [function.include]: failed to open stream: No such file or directory in blabla/zendframework/library/Zend/Loader.php on line 83

Warning: include() [function.include]: Failed opening 'router.php' for inclusion (include_path='blalba;....') in blabla/zendframework/library/Zend/Loader.php on line 83

Maybe cause is same as in ZF-6658

<pre class="highlight"> 
if (class_exists($plugin))

in Zend_Application_Bootstrap_BootstrapAbstract::getPluginResource()


Posted by Miroslav Kubelik (koubel) on 2009-08-06T09:50:07.000+0000

There is a patch, it solves also ZF-6658 and ZF-6672 I think, please consider to apply this one.

Posted by Miroslav Kubelik (koubel) on 2009-08-06T09:57:45.000+0000

still presented in 1.9.0

Posted by Matthew Weier O'Phinney (matthew) on 2009-08-06T10:39:15.000+0000

Patch applied to trunk and 1.9 release branch.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.