Issues

ZF-7799: Zend_Mail Blank line above all emails sent

Issue Type: Bug Created: 2009-09-08T04:48:35.000+0000 Last Updated: 2009-09-18T11:24:40.000+0000 Status: Resolved Fix version(s): - 1.9.3 (22/Sep/09)

Reporter: Dave James Miller (davejamesmiller) Assignee: Benjamin Eberlei (beberlei) Tags: - Zend_Mail

Related issues: Attachments: - patch_ZF7799.diff

Description

When Zend_Mail sends an email, there is one too many blank lines between the headers and the body. Most email clients seem to ignore this, but Gmail shows the blank line.

As far as I can tell, Zend_Mail_Transport_Abstract::_prepareHeaders() always puts a new line after the headers, then Zend_Mail_Transport_Sendmail::_sendMail() passes this straight to the mail() function. Putting trim() in either function solves it for me, but I have not tested other transports.

Comments

Posted by Benjamin Eberlei (beberlei) on 2009-09-18T05:01:26.000+0000

Confirmed on outlook 2007, it also shows the additional blank line.

Posted by Benjamin Eberlei (beberlei) on 2009-09-18T05:43:01.000+0000

I have checked this issue and it appears to be a Sendmail Transport specific issue.

I will add a patch and unittest and apply that tonight when i have my SVN account credentials with me ;)

Posted by Benjamin Eberlei (beberlei) on 2009-09-18T11:24:40.000+0000

Fixed in trunk and merged back into 1.9 release branch

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts