Issues

ZF-8027: No getAdapter() to parallel setAdapter()

Issue Type: Improvement Created: 2009-10-07T09:01:28.000+0000 Last Updated: 2009-10-23T03:05:50.000+0000 Status: Resolved Fix version(s): - 1.10.0 (27/Jan/10)

Reporter: Michael Stillwell (mjs) Assignee: michael depetrillo (klassicd) Tags: - Zend_Http_Client

Related issues: - ZF-8107

Attachments:

Description

Zend_Http_Client contains a setAdapter() method, but not a getAdapter() method. This makes various activities such as debugging (i.e. you need to figure out which adapter class is being used) more difficult.

Comments

Posted by michael depetrillo (klassicd) on 2009-10-16T23:09:06.000+0000

getAdapter method added.

Posted by Kazusuke Sasezaki (sasezaki) on 2009-10-17T03:23:43.000+0000

Is this issue's type a "bug"? (Maybe "Improvement".)

And, I fear that bug may be caused by getAdapter(). Adapter's method is not intend to using from other component.

If there is necessary to debugging, I suggest to doing write a Extend-Class.

Posted by Kazusuke Sasezaki (sasezaki) on 2009-10-20T04:59:30.000+0000

I created new issue.

Posted by Satoru Yoshida (satoruyoshida) on 2009-10-20T18:28:23.000+0000

I updated Issue Type, Affects Version and Fix Version.

Posted by Michael Stillwell (mjs) on 2009-10-23T03:05:50.000+0000

I don't think this patch is quite right:

  1. Direct references to "adapter" in request() should instead use the new getAdapter(). (Or do $adapter = $this->getAdapter() to create a local copy, etc.)
  2. The getAdapter() method in Zend_Gdata_HttpClient is no longer necessary.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts