Issues

ZF-8463: Zend_Tool_Framework_Provider_Repository->_parseName assumes all class providers have _ in their name (patch attached)

Issue Type: Bug Created: 2009-12-04T03:40:19.000+0000 Last Updated: 2010-10-21T08:13:12.000+0000 Status: Resolved Fix version(s): - 1.11.0 (02/Nov/10)

Reporter: Janez Novak (shadow80k) Assignee: Ralph Schindler (ralph) Tags: - Zend_Tool

Related issues: Attachments:

Description

$providerName = substr($className, strrpos($className, '_')+1); assumes, that className contains _ If you have your onw Providers this might not be true!

So above should be changed into

    if (false !== $pos = strrpos($className, '_')) {
        $providerName = substr($className, $pos + 1);
    } else {
        $providerName = $className;
    }

Comments

Posted by Janez Novak (shadow80k) on 2009-12-04T04:01:35.000+0000

It seems that the same applies to the: Zend_Tool_Framework_Provider_Signature->_processName

$name = substr($className, strrpos($className, '_')+1);

should be if (false !== $pos = strrpos($className, '_')) { $name = substr($className, $pos + 1); } else { $name = $className; }

Posted by Ralph Schindler (ralph) on 2010-10-21T08:13:08.000+0000

Fixed in r23201 in trunk & r23202 in release branch 1.11 (as part of ZF-9397)

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts