Issues

ZF-8517: Wrong key for ´searchAttr´ in ´storeParams´ ´url´ on load when using setValue() on Zend_Dojo_Form_Element_FilteringSelect

Issue Type: Bug Created: 2009-12-10T07:37:19.000+0000 Last Updated: 2012-11-20T20:52:58.000+0000 Status: Closed Fix version(s): Reporter: Webdevilopers (tridem) Assignee: None Tags: - Zend_Dojo

Related issues: Attachments:

Description

I use a simple filteringSelect in a form using the declarative method.

<pre class="highlight">
$fooElem = new Zend_Dojo_Form_Element_FilteringSelect(
    'foo',
    array(
        'label' => 'foo',
        'storeId'   => 'fooStore',
        'storeType' => 'dojox.data.QueryReadStore',
        'storeParams' => array(
            'url' => '/issues/ajax/data'
        ),
        'dijitParams' => array(
            'searchAttr' => 'name'
        )
    )
);
#$fooElem->setValue('xxx');

The store gets the data from the following url on load:

<pre class="highlight">
<a href="/issues/ajax/data?name=&start=0">http://.../issues/ajax/data?name=&start=0</a>

The key for the ´searchAttr´ in the query string is named correctely as ´name´. This happens by default even without setting it explicitly in the ´dijitParams´ array.

Next I set the value on the element:

<pre class="highlight">
$fooElem->setValue('xxx');

For some reason the key for the ´searchAttr´ in the query string has changed into ´id´, allthough it is explicitly set in the ´dijitParams´ array:

<pre class="highlight">
<a href="/issues/ajax/data?id=xxx&start=0">http://.../issues/ajax/data?id=xxx&start=0</a>

The programmatic method acts the same way. This is the ´zendDijits´ Code:

<pre class="highlight">
var zendDijits = [{"id":"foo","params":{"store":"fooStore","searchAttr":"name","dojoType":"dijit.form.FilteringSelect",{"id":null,"params":{"dojoType":"dijit.form.Form"];

The element created looks like this:

<pre class="highlight">

It obviously includes invalid tags. See issue http://framework.zend.com/issues/browse/ZF-6052!

Unfortunately I can't see any difference between the code that could cause the wrong url. So I guess this problem occurs in dojo itself?!

Comments

Posted by Rob Allen (rob) on 2012-11-20T20:52:58.000+0000

Bulk change of all issues last updated before 1st January 2010 as "Won't Fix".

Feel free to re-open and provide a patch if you want to fix this issue.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts