Issues

ZF-8981: Zend_Application_Resource_Mail and registering default transport with ini file

Issue Type: Bug Created: 2010-01-27T21:50:38.000+0000 Last Updated: 2010-02-01T12:02:48.000+0000 Status: Resolved Fix version(s): - 1.10.1 (10/Feb/10)

Reporter: Marko Korhonen (back-2-95) Assignee: Dolf Schimmel (Freeaqingme) (freak) Tags: - Zend_Application_Resource

  • Zend_Mail
  • Zend_Mail_Storage

Related issues: Attachments:

Description

Hi,

When using new Mail resource and ini files and register option for Zend_Transport:

resources.mail.transport.register = true // does not work, as it is converted to (int) 1

but as string it works: resources.mail.transport.register = "true"

In Zend_Application_Resource_Mail and in method getMail() there is following code:

<pre class="highlight">
if(!isset($options['transport']['register']) ||
                   (isset($options['transport']['register']) &&
                        !is_numeric($options['transport']['register']) &&
                        (bool) $options['transport']['register'] == true))
                {
                    Zend_Mail::setDefaultTransport($this->_transport);
                }

br, Marko

Comments

Posted by Dolf Schimmel (Freeaqingme) (freak) on 2010-02-01T12:02:48.000+0000

Resolved issue, thank you for reporting.

Have you found an issue?

See the Overview section for more details.

Copyright

© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.

Contacts