ZF-9937: Problems with arrays

Issue Type: Bug Created: 2010-06-02T17:02:54.000+0000 Last Updated: 2010-06-03T04:05:50.000+0000 Status: Resolved Fix version(s): - 1.10.6 (22/Jun/10)

Reporter: Sandra Schneider (haruka) Assignee: Thomas Weidner (thomas) Tags: - Zend_Locale

Related issues: Attachments:


After updating from 1.10.4 to 1.10.5 i got a php warning:

<pre class="highlight">

Line 812 is:

But $locale may not be an array for array_key_exists(). So I guess, just a ! is missing: ```


Posted by Dolf Schimmel (Freeaqingme) (freak) on 2010-06-02T17:05:22.000+0000

How can one reproduce the issue?

Posted by Sandra Schneider (haruka) on 2010-06-02T17:45:41.000+0000

I got this error while calling: ```

$someArray is an array with two elements, 'cause the translation in my po-file has two placeholders.

Posted by Thomas Weidner (thomas) on 2010-06-03T00:35:06.000+0000

Is $this->translate an object of Zend_Translate? Or is $this a view helper?

Because Zend_Translate does not support view operations and the second parameter for Zend_Translate is the language and not a placeholder.

Posted by Sandra Schneider (haruka) on 2010-06-03T02:28:46.000+0000

$this is an instance of Zend_View. So $this->translate() calls the view helper.

Posted by Thomas Weidner (thomas) on 2010-06-03T04:05:50.000+0000

Not reproduceable for me, wether in trunk nor in branch. Probably already fixed in past.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.