ZF-9984: Wrong $_config in Zend_Http_Client_Adapter_Proxy

Issue Type: Bug Created: 2010-06-14T03:44:30.000+0000 Last Updated: 2010-11-20T09:20:42.000+0000 Status: Resolved Fix version(s): - 1.10.6 (22/Jun/10)

Reporter: Radek (salac.r) Assignee: Shahar Evron (shahar) Tags: - Zend_Http_Client

Related issues: - ZF-9143



Hi, in Zend_Http_Client_Adapter_Proxy which is extended from Zend_Http_Client_Adapter_Socket is missing option in $_config sslusecontext => false.

That missing option cuase PHP notice: Undefined index sslusecontext in Zend/Http/Client/Adapter/Socket.php on line 205



Posted by Shahar Evron (shahar) on 2010-06-14T03:55:58.000+0000

I'm pretty sure this is a dupe of ZF-9143, which has been fixed a few months ago. Have you tried with the latest ZF release?

Posted by Shahar Evron (shahar) on 2010-06-15T01:45:03.000+0000

The fix was never merged to the release branch, now it is. Fixed in both trunk and branches/release-1.10, will be included in the next maintenance release.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.