ZF2-176: Adapt several phpunit functions to be compatible with PHPUnit 3.6

Issue Type: Unit Tests: Improvement Created: 2012-02-25T10:12:02.000+0000 Last Updated: 2012-05-31T15:53:24.000+0000 Status: Resolved Fix version(s): Reporter: Maks 3w (maks3w) Assignee: Maks 3w (maks3w) Tags: - Zend\Db

  • Zend\Feed
  • Zend\Gdata
  • Zend\Http
  • Zend\Paginator
  • Zend\Registry
  • Amazon
  • Delicious
  • DeveloperGarden
  • Technorati
  • WindowsAzure

Related issues: Attachments:


Adapt unit tests to be executed under PHPUnit 3.6

  • Change assertType to assertInstanceOf or assertInternalType where aplicable


Posted by Maks 3w (maks3w) on 2012-02-25T13:24:39.000+0000

Pull request #836

Posted by Pádraic Brady (padraic) on 2012-02-25T15:20:38.000+0000

Just a note that the pull request has been reviewed. Just to need to confirm when we're adopting PHPUnit 3.6 before merging it. Thanks!

Posted by Pádraic Brady (padraic) on 2012-02-25T17:07:11.000+0000

Request #836 merged into ZF2 master

Posted by Matthew Weier O'Phinney (matthew) on 2012-02-25T23:08:44.000+0000

Here's your confirmation: definitely moving to 3.6 for ZF2.

Have you found an issue?

See the Overview section for more details.


© 2006-2016 by Zend, a Rogue Wave Company. Made with by awesome contributors.

This website is built using zend-expressive and it runs on PHP 7.